Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Turn signal/tail light issues
#1
My 05 is having a strange issue. It started out with my
right side turn signal not working. It would blink once
then stop unless I applied the brakes and/or turned the
parking lights on. Then it started working properly
again for about two months. A couple of weeks ago, it
started doing it again. Sometimes it would work with the
parking lights on, other times it wouldn't. Now it
doesn't work at all. Now, my tail lights and brake lights don't work -
either side! The only lights on the rear that work is the left turn signal. I was told in another forum it is probably
a grounding issue but that was before the tail lights
stopped working. I spliced into the taillight ground and ran a parallel ground to the battery and nothing happened. Any ideas?
Reply
#2
Sorry, I haven't heard of anything like that happening.
Your truck hasn't ever been submerged under water has it?
Sound like serious electrical shorts in the circuit somewhere.
06 nismo CC 4X4: SOLD and replaced with 2017 Jeep Unlimited Rubicon; Teraflex 3" lift, 315/70-17 Cooper STT PRO tires on Fuel Trophy wheels, JCR bumpers front and rear w/Warn 9.5cti winch in front, Ace sliders, GraBars, Weathertech window deflectors and floor liners
98 Jeep Wrangler in the garage, 2" lift, 33X12.50 BFG MTs on 15X8 MT Classic Locks, Pioneer/MTX/RF P3 Sound, Borla Header w/Flowmaster
63 and 67 Nissan Patrols (under construction)
Reply
#3
Follow the wires and make sure you have not had any critters behind the lights. I had a similar issue when a mouse chewed the wires in my old car.
[Image: 3gears.gif]06 CC 4X2 6sp Avalanche White NISMO SPORT[Image: drive.gif]
[Image: 43d20b1b.jpg]
Click on the picture for my Frontier thread
Reply
#4
If the ground is not the issue, check also the multifunction switch and relays.
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  2008 4x4 Frontier known issues? jayclev 1 1,254 09-13-2017, 11:45 AM
Last Post: mdawg4x4
  Check Engine Light napiers04 1 1,428 04-02-2017, 09:48 AM
Last Post: mdawg4x4
  Emission/Evap Light FRONT4X 5 4,656 02-27-2014, 07:31 PM
Last Post: mdawg4x4
  Truck Still Not Performing Major Issues Please Help silviarunner 5 3,991 08-14-2013, 09:18 AM
Last Post: markspend01
  L.E.D. Tail light Bulbs NismoFrontier04 1 3,280 05-26-2013, 09:21 PM
Last Post: Shift_Avenger
  Turn signals problem NismoFrontier04 1 2,518 10-18-2012, 09:25 PM
Last Post: Shift_Avenger
  02 Frontier KA24DE Fuel Pressure values and issues OE812 1 2,674 07-29-2012, 08:45 AM
Last Post: mdawg4x4
  "Engine Service Soon" light NismoFrontier04 8 8,293 10-24-2011, 08:39 PM
Last Post: NismoFrontier04
  Fog Light Mount Cracks BlackTigerSE 2 3,705 02-09-2011, 01:04 PM
Last Post: mdawg4x4
  Check Engine Light :( - Fuel Sensor Shift_Avenger 51 35,731 01-10-2011, 05:58 PM
Last Post: mdawg4x4

Forum Jump:


Users browsing this thread: 1 Guest(s)